My CDL-reading was off a bit yesterday, so:
On Tue, Jan 31, 2017 at 1:22 AM, Jonathan Gregory <j.m.gregory at reading.ac.uk
> wrote:
> So, for example, we could
> store three timeseries, each applying to a collection of polygons, like
> this:
>
> dimensions:
> station = 3; // collections of polygons
> time = UNLIMITED;
> node = 24; // = 4 + 3 + 3 + 3 + 5 + 3 + 3
> variables:
> float flow(station,time) ;
> flow:units="m3 s-1";
> flow:topology="SOMETHING";
> double time(time) ;
> time:standard_name = "time";
> time:units = "days since 1970-01-01 00:00:00" ;
> int SOMETHING(station); // number of polygons in each collection
> SOMETHING:node_coordinates="lon lat";
> SOMETHING:geometry_type="multipolygon";
> SOMETHING:nodes=4, 3, 3, 3, 5, 3, 3; // number of nodes in each
> polygon
>
I really don't like storing info like this in an attribute -- I think it
should be another variable, instead. it is a bit tricky with "nested" data
like this, but yu can link variables together with something like:
int SOMETHING(station); // number of polygons in each collection
SOMETHING:node_coordinates="lon lat";
SOMETHING:geometry_type="multipolygon";
SOMETHING:node_count="node_count_1"
int node_count_1(num_nodes);
...
data
node_count_1 = 4, 3, 3, 3, 5, 3, 3;
Thus I
> have combined the two variables I suggested last time (number_of_parts and
> number_of_nodes) into SOMETHING.
>
I think we should come up with a better name here -- it would help be parse
it anyway :-)
-CHB
--
Christopher Barker, Ph.D.
Oceanographer
Emergency Response Division
NOAA/NOS/OR&R (206) 526-6959 voice
7600 Sand Point Way NE (206) 526-6329 fax
Seattle, WA 98115 (206) 526-6317 main reception
Chris.Barker at noaa.gov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.cgd.ucar.edu/pipermail/cf-metadata/attachments/20170201/8ca18bdc/attachment.html>
Received on Wed Feb 01 2017 - 09:53:14 GMT